The Hyper Realm - Current Outage – Incident details
Get updates
Email
Discord
Google Chat
API
Get updates
All systems operational
Current Outage
Resolved
Major outage
Started about 2 months ago
Lasted 1 day
Affected
The Hyper Realm
Major outage from 5:09 AM to 2:05 PM
Life Live Network Website
Major outage from 5:09 AM to 2:05 PM
Updates
Resolved
May 06, 2025 at 2:05 PM
Resolved
May 06, 2025 at 2:05 PM
This incident has been resolved.
Investigating
May 05, 2025 at 5:09 AM
Investigating
May 05, 2025 at 5:09 AM
We are currently investigating this incident.